Quantum Secular Labs / Blog / Advisories
CVE-2026-58162: Apache Traffic Server: Improper Certificate Validation
CVE-2026-58162 is rated critical with a CVSS v3.1 base score of 10.0 and affects Apache Traffic Server. Per its scoring, it can be exploited over the network, without authentication, without any user interaction.
Vulnerability description
The Apache Traffic Server certifier plugin generates certificates based on attacker-controlled client SNI. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
Severity breakdown
CVSS v3.1 10.0: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H
- Attack vector: Network. Exploitable remotely over the network, with no need for local or physical access.
- Attack complexity: Low. No special conditions; the attack can be repeated reliably.
- Privileges required: None. No account or prior access is needed.
- User interaction: None. No action from any user is needed.
- Scope: Changed. Impact reaches beyond the vulnerable component to other resources.
- Confidentiality impact: Low. Some information is exposed.
- Integrity impact: High. Total loss of integrity; data or system state can be fully modified.
- Availability impact: High. Total loss of availability; the component can be shut down.
Underlying weakness
CWE-295: Improper Certificate Validation
The product does not validate, or incorrectly validates, a certificate.
Affected products
- Apache Traffic Server: from 8.0.0 up to and including 8.1.9; from 9.0.0 before 9.2.15; from 10.0.0 before 10.1.4