Quantum Secular Labs / Blog / Advisories
CVE-2018-1000613: Legion of the Bouncy Castle Legion of the Bouncy Castle Java Cryptography APIs 1.58 up to but not including…
CVE-2018-1000613 is rated critical with a CVSS v3.1 base score of 9.8 and NVD lists 24 affected products, including Bouncycastle Bc Java. Per its scoring, it can be exploited over the network, without authentication, without any user interaction. The scored impact on confidentiality, integrity and availability is the highest available.
Vulnerability description
Legion of the Bouncy Castle Legion of the Bouncy Castle Java Cryptography APIs 1.58 up to but not including 1.60 contains a CWE-470: Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in XMSS/XMSS^MT private key deserialization that can result in Deserializing an XMSS/XMSS^MT private key can result in the execution of unexpected code. This attack appear to be exploitable via A handcrafted private key can include references to unexpected classes which will be picked up from the class path for the executing application. This vulnerability appears to have been fixed in 1.60 and later.
Severity breakdown
CVSS v3.1 9.8: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Attack vector: Network. Exploitable remotely over the network, with no need for local or physical access.
- Attack complexity: Low. No special conditions; the attack can be repeated reliably.
- Privileges required: None. No account or prior access is needed.
- User interaction: None. No action from any user is needed.
- Scope: Unchanged. Impact stays within the vulnerable component.
- Confidentiality impact: High. Total loss of confidentiality; sensitive data can be fully disclosed.
- Integrity impact: High. Total loss of integrity; data or system state can be fully modified.
- Availability impact: High. Total loss of availability; the component can be shut down.
Underlying weakness
CWE-470: Use of Externally-Controlled Input to Select Classes or Code
The product uses external input with reflection to select which classes or code to use, but it does not sufficiently prevent the input from selecting improper classes or code.
Affected products
- Bouncycastle Bc Java: from 1.58 before 1.60
- Netapp Oncommand Workflow Automation: all versions listed by NVD
- Opensuse Leap: 15.1
- Oracle API Gateway: 11.1.2.4.0
- Oracle Banking Platform: 2.6.0; 2.6.1; 2.6.2
- Oracle Business Process Management Suite: 11.1.1.9.0; 12.1.3.0.0; 12.2.1.3.0
- Oracle Business Transaction Management: 12.1.0
- Oracle Communications Application Session Controller: 3.7.1; 3.8.0
- Oracle Communications Converged Application Server: before 7.0.0.1; 7.0.0.1
- Oracle Communications Convergence: 3.0.2
- Oracle Communications Diameter Signaling Router: 8.0.0; 8.1; 8.2; 8.2.1
- Oracle Communications Webrtc Session Controller: before 7.2; 7.2
- Oracle Data Integrator: 12.2.1.3.0
- Oracle Enterprise Manager Base Platform: 12.1.0.5.0; 13.2.0.0; 13.3.0.0
- Oracle Enterprise Manager For Fusion Middleware: 13.2.0.0; 13.3.0.0
References
- https://github.com/bcgit/bc-java/commit/4092ede58da51af9a21e4825fbad0d9a3ef5a223#diff-2c06e2edef41db889ee14899e12bd574
- https://github.com/bcgit/bc-java/commit/cd98322b171b15b3f88c5ec871175147893c31e6#diff-148a6c098af0199192d6aede960f45dc
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://www.oracle.com/security-alerts/cpuapr2020.html
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
- https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
- https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00011.html
- https://security.netapp.com/advisory/ntap-20190204-0003/
- https://lists.apache.org/thread.html/rf1bbc0ea4a9f014cf94df9a12a6477d24a27f52741dbc87f2fd52ff2%40%3Cissues.geode.apache.org%3E